Cài đặt Dart Code Extension cho Visual Studio Code

Xem thêm các chuyên mục:

1- Dart Extension

Có nhiều IDE phức tạp mà nó hỗ trợ Dart thông qua các plugin, chẳng hạn Android Studio, IntelliJ IDEA, Visual Studio Code ... Tùy mục đích mà bạn chọn IDE phù hợp. Nếu bạn chỉ muốn học ngôn ngữ Dart thì Visual Studio Code là một lựa chọn tốt, bởi vì nó là một IDE miễn phí, gọn nhẹ (lightweight) và đầy sức mạnh.
Theo mặc định Visual Studio Code hỗ trợ sẵn các ngôn ngữ phổ biến (hoặc ngôn ngữ của Microsoft) như C/C++, C#, F#, Visual Basic, HTML, CSS, JavaScript,.. nhưng không bao gồm Dart, vì vậy muốn lập trình Dart trong Visual Studio Code bạn cần phải cài đặt thêm Dart extension.
Chú ý: Nếu bạn muốn học Dart và xa hơn là xây dựng một ứng dụng Flutter viết trên ngôn ngữ Dart thì bạn nên dùng Android Studio. Cả ba Dart, FlutterAndroid Studio đều được tạo ra bởi Google vì vậy bạn sẽ nhận được sự hỗ trợ tốt hơn.
Mở Visual Studio Code, nhấn vào biểu tượng Extensions (hoặc nhấn tổ hợp phím Ctrl+Shift+X), và tìm kiếm các extension với từ khoá "dart" như hình minh hoạ dưới đây, và bạn sẽ nhìn thấy Dart Code Extension xuất hiện tại vị trí đầu tiên trong các kết quả. Nhấn vào nút "Install" để cài đặt.

2- Ví dụ đầu tiên

Xem thêm các chuyên mục: