Installez Dart Code Extension pour Visual Studio Code

View more Tutorials:

1- Dart Extension

Il existe de nombreux IDE complexes qui assistent Dart via des plugins, tels que Android Studio, IntelliJ IDEA, Visual Studio Code, etc. Cela dépend de votre objectif d'utilisation pour choisir un bon IDE. Si vous ne voulez qu'apprendre le langague Dart, Visual Studio Code est un bon choix, car il s'agit d'un IDE gratuit, léger(lightweight) et puissant.
Par défaut, Visual Studio Code assiste les languages populaires (ou les languages de Microsoft) tels que C/C++, C#, F#, Visual Basic, HTML, CSS, JavaScript, etc. mais sans Dart. Par conséquent, pour programmer Dart dans Visual Studio Code, il est nécessaire d'installer Dart extension.
Remarque: Si vous voulez apprendre Dart et en plus, créer une application Flutter écrite sur le langague Dart, vous devez utiliser Android Studio. Dart, Flutter et Android Studio sont tous créés par Google, donc il y aura de meilleurs soutiens.
Ouvrir Visual Studio Code, appuyer sur l'icône Extensions (ou appuyer sur la combinaison Ctrl+Shift+X), et chercher les extension(s) avec le mot-clef "dart" comme dans l'illustration ci-dessous. Vous voyer Dart Code Extension apparue en premier dans les résultats. Appuyer sur "Install" pour installer.

2- Premier exemple

View more Tutorials: