Installation de Ruby et Ruby On Rails sous Ubuntu

View more categories:

1- Ruby & Ruby On Rails

Dans cette publication, je vous explique comment configurer Ruby et Ruby On Rails sur le système d'exploitation Ubuntu, notez que vous pouvez simplement installer Ruby au cas où vous n'avez pas besoin d'un Cadre pour programmer web.
Ruby est un langage de programmation général.
Ruby On Rails est un cadre (framework) écrit dans  Ruby qui aide l'application web de devenir plus facile.

2- Installer RVM

RVM signifie "Ruby Version Manager" (Le gestionnaire version Ruby). RVM fournit un moyen efficace de configurer Ruby avec une certaine version sur Ubuntu. Normalement, nous allons configurer la dernière version de Ruby.
D'abord, vous devez installer  cURL et  gnupg2:

sudo apt-get install curl

sudo apt-get install gnupg2

Installer RVM:

Avant d'installer RVM, d'abord vous devez importer une clé publique (public key) sur votre système, puis utiliser cURL pour installer RVM.
gpg2 --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3


curl -sSL https://get.rvm.io | bash -s stable
Après avoir installé RVM, vous devez fermer la fenêtre Terminal actuelle et ouvrir une autre fenêtre Terminal pour fonctionner.
Installez toutes les dépendances pour installer Ruby automatiquement sur le système en utilisant la commande ci-dessous.

rvm requirements
Vous pouvez maintenant utiliser la commande pour lister les versions de Ruby qui ont été diffusées:

rvm list known

3- Installer Ruby

Utilisez la déclaration suivante qui vous aide à connaître les versions Ruby actuelle.

rvm list known
Nous allons installer la dernière version.

rvm install 2.4.0

Spécifiez la version par défaut à utiliser.

Dans l'étape ci-dessus, vous avez déjà installé Ruby, notez que vous pouvez installer une ou plusieurs versions Ruby différentes sur Ubuntu. Vous devez spécifier la version par défaut à utiliser:

rvm use 2.4.0 --default
Remarque: Si vous détectez l'erreur suivante, vous pouvez voir comment la rectifier à la fin de ce poste.
RVM is not a function, selecting rubies with 'rvm use ...' will not work.

You need to change your terminal emulator preferences to allow login shell.
Sometimes it is required to use `/bin/bash --login` as the command.
Please visit https://rvm.io/integration/gnome-terminal/ for a example.

Vérifier la version:

Exécutez la déclaration suivante pour vérifier la version Ruby par défaut utilisée:

ruby --version

4- Installer Rails

Pour installer la dernière version de "Ruby on Rails", vous devez exécuter l'instruction suivante:
gem install rails

rails -v
Ou installez une version spécifique:

gem install rails --version=5.0.2
Afin de connaître les versions "Ruby on Rails" actuelles disponibles, vous pouvez consulter ici:
Vérifiez la version Rails que vous venez d'installer.

5- Annexe: Correction d'erreur

Si vous détectez une certaine erreur après avoir spécifié la version Ruby par défaut à utiliser:
RVM is not a function, selecting rubies with 'rvm use ...' will not work.

You need to change your terminal emulator preferences to allow login shell.
Sometimes it is required to use `/bin/bash --login` as the command.
Please visit https://rvm.io/integration/gnome-terminal/ for a example.
  • Edit/Profile Preferences
Fermez la fenêtre Terminal actuelle et ouvrez une nouvelle fenêtre Terminal pour opérer.

View more categories: